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Veeam Management Agent UI Mode Incorrect

Management agent fields are incorrect, it displays the address and port only

Problem:

The Management Agent displays incorrect fields and is not able to connect to the VAC (see below image).

Management Agent UI Gateway Mode

Cause:

The problem is related to corruption in the WMI repository. The backup logs will confirm errors with WMI RPC’s (Remote Procedure Calls).

According to Microsoft’s documentation:

“Windows Management Instrumentation (WMI) is the Microsoft implementation of Web-Based Enterprise Management (WBEM), which is an industry initiative to develop a standard technology for accessing management information in an enterprise environment.”

For more information about WMI please visit docs.microsoft.com.

Solution:

Close the Management Agent.

Run a Command Prompt as Administrator and type the following commands to verify the consistency/health of the WMI repository:

 winmgmt /verifyrepository

If it returns “inconsistent” type the following command:

winmmgmt /salvagerepository

If it returns “unable to salvage” type the following command:

winmgmt /resetrepository

If no errors are returned after attempting to salvage or reset, verify the consistency of the WMI repository again:

winmgmt /verifyrepository

Run the Management Agent.

If The Solution Fails:

  1. Uninstall the Management Agent.
  2. Rerun the above commands.
  3. Reboot Windows.
  4. Reinstall again.

Addition Solutions:

Try running the Dot Net Framework Repair Tool.

Try running the script provided by Veeam support. *CAUTION the script rebuilds WMI and can cause applications to stop working – backup first! For example, this script re-registers WMI DLL’s. First, try the above solutions.

To confirm this script may need to be run start by verifying the consistency of the WMI repository.

winmgmt /verifyrepository

If it returns “inconsistent” you may choose to proceed.

Copy the following code to a new text file and name it reregister-wmi.bat (make sure you remove the .txt file extension):

echo off
sc config winmgmt start= disabled
net stop winmgmt /y
%systemdrive%
cd %windir%\system32\wbem
for /f %%s in ('dir /b *.dll') do regsvr32 /s %%s
wmiprvse /regserver
winmgmt /regserver
sc config winmgmt start= auto
net start winmgmt
for /f %%s in ('dir /s /b *.mof *.mfl') do mofcomp %%s

Run a Command Prompt as Administrator and run the .bat file from the Command Prompt.

C:\reregister-wmi.bat

Watch the Command Prompt for any errors. Even if there are errors it may have worked partially. Verify the consistency of the WMI repository again:

winmgmt /verifyrepository

If it returns “inconsistent”, try running the commands from the “Solution” section again.

If it returns “consistent” the WMI repository has been repaired successfully and the Management Agent will be operational.

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